易语言置图片二值化

这段时间做游戏辅助时考虑到图像识别,用到了大漠ocr,但是占用cup太多了,自己想了个办法,就是先截图,然后把图片转成白底黑字,再拿预先做好的图一个一个地去比较。下面是把图片转成白底黑字的源码。

 

支持库 BmpOperate

子程序名 返回值类型 公开 备注
置图片二值化 字节集
参数名 类型 参考 可空 数组 备注
图片数据 字节集
文本颜色 整数型
变量名 类型 静态 数组 备注
位图1 位图
位图2 位图
a 整数型
b 整数型
位图1.载入数据 (图片数据)
位图2.载入数据 (图片数据)
计次循环首 (位图1.取宽度 (), a)
计次循环首 (位图1.取高度 (), b)
判断开始 (位图1.取某点颜色 (a - 1, b - 1) = 文本颜色)
位图2.置某点颜色 (a - 1, b - 1, #黑色)
默认
位图2.置某点颜色 (a - 1, b - 1, #白色)
判断结束
计次循环尾 ()
计次循环尾 ()
返回 (位图2.取位图数据 ())
‘ 此源码出自 YXZ’s Blog http://yxz.me/ 转载请保留此句
‘ Transformed by YXZ’s e-Assist
下面是易语言源代码,请直接复制使用!
.版本 2
.支持库 BmpOperate

.子程序 置图片二值化, 字节集, 公开
.参数 图片数据, 字节集
.参数 文本颜色, 整数型
.局部变量 位图1, 位图
.局部变量 位图2, 位图
.局部变量 a, 整数型
.局部变量 b, 整数型

位图1.载入数据 (图片数据)
位图2.载入数据 (图片数据)
.计次循环首 (位图1.取宽度 (), a)
.计次循环首 (位图1.取高度 (), b)
.判断开始 (位图1.取某点颜色 (a - 1, b - 1) = 文本颜色)
位图2.置某点颜色 (a - 1, b - 1, #黑色)
.默认
位图2.置某点颜色 (a - 1, b - 1, #白色)
.判断结束

.计次循环尾 ()
.计次循环尾 ()
返回 (位图2.取位图数据 ())

′ 此源码出自 YXZ′s Blog http://yxz.me/ 转载请保留此句

 

 

 
(转载请注明出处YXZ’s Blog http://www.cleveryxz.com/

 

原创文章,转载请注明: 转载自YXZ’s Blog

本文链接地址: 易语言置图片二值化

2 Responses

  1. kiio 2012 年 2 月 7 日 / 下午 4:48

    学习了谢谢

  2. Narota 2012 年 3 月 26 日 / 下午 8:33

    Thanks for the insight. It brigns light into the dark!

发表评论

电子邮件地址不会被公开。 必填项已用*标注

您可以使用这些HTML标签和属性: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>