易语言取Unix时间

 

子程序名 返回值类型 公开 备注
取当前Unix时间 长整数型
变量名 类型 静态 数组 备注
时间 日期时间型
时间 = 取现行时间 ()
返回 (Unix时间戳记正转 (时间, 真, 真))
子程序名 返回值类型 公开 备注
Unix时间戳记正转 长整数型
将时间类型值转到长整型的标准UNIX使用的格林威治时间戳记
参数名 类型 参考 可空 数组 备注
时间值 日期时间型 要转换的时间值
是否为秒 逻辑型
设置返回的时间戳记值单位 真:秒 假:毫秒 默认为真
是否为北京时间 逻辑型
默认为真
变量名 类型 静态 数组 备注
初始时间 日期时间型
如果真 (是否为空 (是否为北京时间))
    是否为北京时间 = 真
如果真结束
如果 (是否为北京时间)
    初始时间 = 到时间 (“1970-01-01 08:00:00”)
否则
    初始时间 = 到时间 (“1970-01-01 00:00:00”)
如果结束
如果真 (是否为空 (是否为秒))
    是否为秒 = 真
如果真结束
如果 (是否为秒)
    返回 (取时间间隔 (时间值, 初始时间, #秒))
否则
    返回 (取时间间隔 (时间值, 初始时间, #秒) × 1000)
如果结束
返回 (取时间间隔 (时间值, 初始时间, #秒))
子程序名 返回值类型 公开 备注
Unix时间戳记反转 日期时间型
将标准UNIX使用的格林威治时间戳记转到易系统时间日期格式
参数名 类型 参考 可空 数组 备注
时间戳记值 长整数型 要转换的时间戳记值
是否为秒 逻辑型
时间戳记值单位 真:秒 假:毫秒 默认为真
是否为北京时间 逻辑型
默认为真,
变量名 类型 静态 数组 备注
初始时间 日期时间型
如果真 (是否为空 (是否为北京时间))
    是否为北京时间 = 真
如果真结束
如果 (是否为北京时间)
    初始时间 = 到时间 (“1970-01-01 08:00:00”)
否则
    初始时间 = 到时间 (“1970-01-01 00:00:00”)
如果结束
如果真 (是否为空 (是否为秒))
    是否为秒 = 真
如果真结束
如果 (是否为秒)
    返回 (增减时间 (初始时间, #秒, 时间戳记值))
否则
    返回 (增减时间 (初始时间, #秒, 时间戳记值 ÷ 1000))
如果结束
返回 (增减时间 (初始时间, #秒, 时间戳记值))
‘ 此源码出自 YXZ’s Blog http://yxz.me/ 转载请保留此句
‘ Transformed by YXZ’s e-Assist

下面是易语言源代码,请直接复制使用!
.版本 2

.子程序 取当前Unix时间, 长整数型
.局部变量 时间, 日期时间型

时间 = 取现行时间 ()
返回 (Unix时间戳记正转 (时间, 真, 真))

.子程序 Unix时间戳记正转, 长整数型, 公开, 将时间类型值转到长整型的标准UNIX使用的格林威治时间戳记
.参数 时间值, 日期时间型, , 要转换的时间值
.参数 是否为秒, 逻辑型, 可空, 设置返回的时间戳记值单位 真:秒  假:毫秒   默认为真
.参数 是否为北京时间, 逻辑型, 可空, 默认为真
.局部变量 初始时间, 日期时间型

.如果真 (是否为空 (是否为北京时间))
是否为北京时间 = 真
.如果真结束
.如果 (是否为北京时间)
初始时间 = 到时间 (“1970-01-01 08:00:00”)
.否则
初始时间 = 到时间 (“1970-01-01 00:00:00”)
.如果结束
.如果真 (是否为空 (是否为秒))
是否为秒 = 真
.如果真结束
.如果 (是否为秒)
返回 (取时间间隔 (时间值, 初始时间, #秒))
.否则
返回 (取时间间隔 (时间值, 初始时间, #秒) × 1000)
.如果结束
返回 (取时间间隔 (时间值, 初始时间, #秒))

.子程序 Unix时间戳记反转, 日期时间型, 公开, 将标准UNIX使用的格林威治时间戳记转到易系统时间日期格式
.参数 时间戳记值, 长整数型, , 要转换的时间戳记值
.参数 是否为秒, 逻辑型, 可空, 时间戳记值单位 真:秒  假:毫秒   默认为真
.参数 是否为北京时间, 逻辑型, 可空, 默认为真,
.局部变量 初始时间, 日期时间型

.如果真 (是否为空 (是否为北京时间))
是否为北京时间 = 真
.如果真结束
.如果 (是否为北京时间)
初始时间 = 到时间 (“1970-01-01 08:00:00”)
.否则
初始时间 = 到时间 (“1970-01-01 00:00:00”)
.如果结束
.如果真 (是否为空 (是否为秒))
是否为秒 = 真
.如果真结束
.如果 (是否为秒)
返回 (增减时间 (初始时间, #秒, 时间戳记值))
.否则
返回 (增减时间 (初始时间, #秒, 时间戳记值 ÷ 1000))
.如果结束
返回 (增减时间 (初始时间, #秒, 时间戳记值))

′ 此源码出自 YXZ′s Blog http://yxz.me/ 转载请保留此句

原创文章,转载请注明: 转载自YXZ’s Blog

本文链接地址: 易语言取Unix时间

发表评论

电子邮件地址不会被公开。 必填项已用*标注

您可以使用这些HTML标签和属性: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>