易语言取父目录

 

子程序名 返回值类型 公开 备注
取中间文本 文本型
取两段字符之间的文本(不提取两段字符)
参数名 类型 参考 可空 数组 备注
文本 文本型 欲被操作的文本
前一依据 文本型 欲取文本的前段字符
后一依据 文本型 欲取文本的后段字符
起始位置 整数型
欲开始找前一依据的位置,小于1默认为1
变量名 类型 静态 数组 备注
b 整数型
a 文本型
c 整数型
如果真 (起始位置 < 1)
    起始位置 = 1
如果真结束
a = 文本
b = 寻找文本 (a, 前一依据, 起始位置, 假)
c = 寻找文本 (a, 后一依据, b + 1, 假)
返回 (取文本中间 (a, b + 取文本长度 (前一依据), c - b - 取文本长度 (后一依据)))
‘ 此源码出自 YXZ’s Blog http://yxz.me/ 转载请保留此句
‘ Transformed by YXZ’s e-Assist
下面是易语言源代码,请直接复制使用!
.版本 2.子程序 取中间文本, 文本型, 公开, 取两段字符之间的文本(不提取两段字符)
.参数 文本, 文本型, , 欲被操作的文本
.参数 前一依据, 文本型, , 欲取文本的前段字符
.参数 后一依据, 文本型, , 欲取文本的后段字符
.参数 起始位置, 整数型, 可空, 欲开始找前一依据的位置,小于1默认为1
.局部变量 b, 整数型
.局部变量 a, 文本型
.局部变量 c, 整数型

.如果真 (起始位置 < 1)
起始位置 = 1
.如果真结束
a = 文本
b = 寻找文本 (a, 前一依据, 起始位置, 假)
c = 寻找文本 (a, 后一依据, b + 1, 假)
返回 (取文本中间 (a, b + 取文本长度 (前一依据), c - b - 取文本长度 (后一依据)))

′ 此源码出自 YXZ′s Blog http://yxz.me/ 转载请保留此句

原创文章,转载请注明: 转载自YXZ’s Blog

本文链接地址: 易语言取父目录

易语言取中间文本(取两段文本之中的文本)

 

子程序名 返回值类型 公开 备注
取中间文本 文本型
取两段字符之间的文本(不提取两段字符)
参数名 类型 参考 可空 数组 备注
文本 文本型 欲被操作的文本
前一依据 文本型 欲取文本的前段字符
后一依据 文本型 欲取文本的后段字符
起始位置 整数型
欲开始找前一依据的位置,小于1默认为1
变量名 类型 静态 数组 备注
b 整数型
a 文本型
c 整数型
如果真 (起始位置 < 1)
起始位置 = 1
如果真结束
a = 文本
b = 寻找文本 (a, 前一依据, 起始位置, 假)
c = 寻找文本 (a, 后一依据, b + 1, 假)
返回 (取文本中间 (a, b + 取文本长度 (前一依据), c - b - 取文本长度 (前一依据)))
‘ 此源码出自 YXZ’s Blog http://yxz.me/ 转载请保留此句
‘ Transformed by YXZ’s e-Assist
下面是易语言源代码,请直接复制使用!
.版本 2
.子程序 取中间文本, 文本型, 公开, 取两段字符之间的文本(不提取两段字符)
.参数 文本, 文本型, , 欲被操作的文本
.参数 前一依据, 文本型, , 欲取文本的前段字符
.参数 后一依据, 文本型, , 欲取文本的后段字符
.参数 起始位置, 整数型, 可空, 欲开始找前一依据的位置,小于1默认为1
.局部变量 b, 整数型
.局部变量 a, 文本型
.局部变量 c, 整数型.如果真 (起始位置 < 1)
起始位置 = 1
.如果真结束
a = 文本
b = 寻找文本 (a, 前一依据, 起始位置, 假)
c = 寻找文本 (a, 后一依据, b + 1, 假)
返回 (取文本中间 (a, b + 取文本长度 (前一依据), c - b - 取文本长度 (前一依据)))

′ 此源码出自 YXZ′s Blog http://yxz.me/ 转载请保留此句

原创文章,转载请注明: 转载自YXZ’s Blog

本文链接地址: 易语言取中间文本(取两段文本之中的文本)